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III/IV B.Tech (Regular\Supplementary) DEGREE EXAMINATION 

Feb, 2021    Information Technology 

Fifth Semester Introduction to Computer Animation 
Time: Three Hours Maximum: 50 Marks 
Answer all questions from Part-A.                  (1X10= 10 Marks) 
Answer ANY FOUR questions form Part-B.                                                     (4X10=40 Marks) 

Part-A  
1.  Answer all questions                                                                                                                          (1X10=10 Marks) 
 a) What is the importance of pivot?  CO1  
 b) What are the options available in menu set? CO1  
 c) What is hardware texturing? CO1  
 d) What is the purpose of adding spot light? CO2  
 e) What are the different view layouts available in maya? CO2  
 f) What is parenting CO3  
 g) Name the types of IK handles used in rigging CO3  
 h) MEL CO4  
 i) What is texturing? CO4  
 j) What is the purpose of shaders? CO4  

Part-B  
2. a) Explain about creating a ball and floor surface in maya CO1 5M 
 b) Explain about creation of ball bounce animation in maya CO1 5M 

  
3. a) Write about adding texture maps for visual complexity. CO1 5M 
 b) How to use the ball as a particle emitter and add gravity to particles CO1 5M 

  
4. a) Write about the menu sets, shelf and hot box available in maya CO2 5M 
 b) Write about menu items that let developer act on scenes in number of ways CO2 5M 

  
5. a) Explain about building shark body and skeleton joints  CO2 5M 
 b) Explain about binding surface of shark to joints  CO2 5M 

  
6. a) Write about adding IK single chain handles, IK Spline handle and Cluster the 

spline curve 
CO3 5M 

 b) Write about Creation of a ball, Connecting it to shark’s nose and animating them CO3 5M 
  

7. a) Write about adding details to the face of shark CO3 5M 
 b) Write about creation of background lighting in maya CO3 5M 

  
8. a) Explain about texturing water and mapping it as a displacement map. CO4 5M 
 b) Write about layered shaders available in maya CO4 5M 

  
9. a) Write about adding functions to UI in MEL  CO4 5M 
 b) Write about building custom UI script  CO4 5M 

 

 
 
 
 
 
 
 
 
 
 



 
 

PART-A 

1. Answer all questions 

 a) What is the importance of pivot? 

  The pivot point defines the position around which objects or components are rotated and scaled. By default, 
the pivot point of an object or group of objects/components is located at its center. 

b) What are the options available in menu set? 

 Modeling 
 Rigging 
 Animation 
 FX 
 Rendering 

c) What is hardware texturing? 

   hardware textured rendered results as if they were being displayed in an external viewer 

   They are mainly three steps in hardware texturing 

 Texture Blend 
 Texture Filter 
 High Quality Filtering 

d) What is the purpose of adding spot light? 

   Spotlights are usually designed for highlighting specific small areas or points, like display objects, wall         artwork, landscape 
features, or architectural details in one direction. If you need to see far down the path ahead, a spotlight will project a longer, 
narrow beam of illumination. 

e) what are the different view layouts available in maya? 

  Maya has four view layouts 

 Top view 
 Perspective view 
 Front view 
 Side view 

f) What is parenting? 

Parenting  objects  is  way you  can  temporarily  associate  objects  with  other objects, so for example, if  you translate 
the parent object, the child-objects follow. To parent an object. Shift-select a group of objects. The last object you select will be 
the parent. 

g) Name the type of IK handles used in rigging? 

 There are three types of IK handles 
 Single Chain (SC) Handle 
 Rotate Plane (RP) Handle 
 Spline Handle 

h) MEL 

MEL-Maya Embedded Language 

i)  What is texturing? 

Texturing is the process of applying an image to a 3D model. Textures are the flat images that are applied to a model to give it 
colour and detail rather than them being blank and boring. 

j) What is the purpose of shaders? 
The shader (material) allows your objects to render and display properly. If no shader is attached to a surface, an object can't be 
seen when rendered .When you create any objects, Maya assigns a default shader (also called material) to them called Lambert1, 
which has a neutral gray color. 
 
 
 



 
PART-B 

2.a) Explain about creating a ball and floor surface in maya. 

  Creating the ball 

To start, you will build a few simple objects that you animate, texture and render. The first object is a primitive sphere 
which will act as the ball. 

1. Change menu sets 

       From the menu at the left edge of the Status line, select Modeling 

 
2. Create a NURBS sphere 

     A primitive sphere will be used for the ball. It will be built using non-uniform rational bspline (NURBS) geometry. 

Go to the Primitives menu and select Create NURBS → Sphere 

 
3. Change the ball’s radius 

 Select Window → Attribute Editor 
 Click on the makeNurbSphere tab to bring it forward. 
 This tab represents the input node that was created when the sphere was placed into the scene. 
 In the Sphere History section, change the following: Radius to 2. 
 Close the Attribute Editor 

4. Position the ball  
 Select the Move tool. 
 A transform manipulator appears centered on the object   
 Click-drag on the green manipulator handle to move the sphere along the Y-axis. 
 The manipulator turns yellow to indicate that it is active.   

5. Create four view panels 

   At the top right corner of the Perspective view panel, go to the Panels menu and select Layouts  → Four. 

 

6. Reposition the ball 

 In the Front view panel, click-drag on the square center of the manipulator to move the sphere along both the X and the Y 
axes 

Use the manipulator in the various view windows to position the sphere on top of the ground plane as shown below 



 

Create a floor surface 

 1.Create a polygonal plane 

■  In a view panel, press and hold the spacebar to bring up the hotbox.  

■  In the hotbox, select Primitives → Create Polygons → Plane A plane is placed at the origin   

 

     2. Change the plane’s construction history 

      In the Channel box shown at the right side of your screen, click on the polyPlane Input node. 

 
 

2.b) Explain about creation of ball bounce animation in maya 

ANIMATING THE BALL  

You now have your scene set up and ready to animate. Using the ballTranslate node, you will start by keying the overall 
translation of the ball then you will add in the peaks and valleys of the bouncing. 

 

 Setting keys: 

 Set a start key on the ball The current position will be set as a key for frame 1.  
■  Check the Outliner view to make sure that the ballTranslate node is selected.  
■  Press F2 to go to the animation menu set.  
■  From the Keys menu, select Set Key. This places a key at frame 1. 

 

 Set end key on the ball  
        A new position for the ball can be set for frame 60.  



               ■  In the Time slider, change the end frame to 60. This changes the range of the animation to 60              
                frames. 
               ■  Move the Time slider to frame 60 
               ■  Click-drag on the red handle on the sphere to move it along the X-axis. 
               ■  Press the s key to Set Key at this position and time. 
               ■  Playback the results using the Time slider controls. 

 Add intermediate keys 
In order to have the ball hit the ground four times, you will need two more key positions set at frames 20 and 40. Any 
time you want to make sure an object is at a certain place at a certain time, set a key. 
■  Drag the Time slider to frame 20. The ball is positioned based on existing keys.  
■  Press the s key to Set Key.  
■  Drag the Time slider to frame 40.  
■  Press the s key to Set Key.  

 
 Add more intermediate keys 

          To create the peaks of the bounce, you need to set new keys at frames 10, 30 and 50. These keys will      
 
           require that you move the ball into a new position along the Yaxis. 
               ■  Move the Time slider to frame 10.  
               ■  Click-drag on the green Y-axis manipulator to move the sphere up along the Y-axis. 
               ■  Press the s key to Set Key. 
               ■  Repeat these steps for frames 30 and 50 

 
 Set the playback speed 

■  Click on the Animation Preferences button found at the right side of the Time slider. This opens a window that 
lets you set various animation and playback options. Currently, the scene is playing back as fast as it can. Since 
you only have two objects, playback is a little too fast.  

■  In the Playback section, set the following: Playback Speed to Normal.  
■  Click the Save button.  
■  Playback the results using the Time slider controls. 

 Save your work 
■  From the File menu, select Save Scene As...  
■  Enter the name my_ball at the end of the file’s path.  
■  Press the Save button or press the Enter key. 

3.a)Write about adding texure maps for visual complexity. 
  

Positioning the texture 
 When the texture was assigned to the ball, it was mapped to the actual surface of the ball. How this mapping is 
positioned is determined by another shading group node known as the place2DTexture node.  
1 Turn on hardware texturing (if possible) Hardware texturing allows you to see your textures interactively on the screen 
as you work. This helps you visualize your animations and to preview basic rendering effects 
■  Move your cursor over the Perspective window. 
■ From the hotbox, select Shading → Hardware Texturing. 

 
2 Change the positioning nodes attributes  

■  Double-click on the ballSG node’s place2DTexture node to open the Attribute Editor. 
■  In the Attribute Editor, set the following attribute: 

             Repeat UV to 0.5 and 4.000.  
■  You can see the result of this change update in the Multilister icon. If you are using hardware texturing, you can 

also see an update in the Perspective view. 
3 Change the checker color  

■ With the Attribute Editor still open, click on the checker node in the Multilister.  



■  In the Attribute Editor, click on the color swatch. 
■  In the Color Chooser, select any color you want for the second color. 

 
4 Change menu set modes  

■  Press the F5 key to switch to the Render menu set. 
■  From the hotbox, select Render → Render into New Window... 

Oops! The scene renders to black. This is because there are no lights in the scene. You must first add a few 
lights to help the renderer illuminate the scene.  

■  Close the Render View window. 
 
3.b)how to use the ball as a particle emitter and gravity to particles 
  

Change menu sets 
 ■  Press h and with the left mouse button, choose Dynamics from the marking menu to change to 
    that menu set. 
1.Add an emitter to the ball 
 An emitter is a special node that emits particles. This node contains attributes for how the particles will begin their 
motion. 
a) Add the emitter  
■  Select the ball node. 
■  Select Particles → Add Emitter.  
■  Go to frame 1 then playback the scene. 

The ball is now emitting particles from a point at its center. The behaviour of these particles is being animated 
using dynamics. 

b)Edit the number of particles 
■  In the Channel box, double-click on the emitterShape1 node and rename it to waterEmit.  
■  In the Channel box, change the waterEmit node’s Rate to 50.  
■  Playback the scene.  

The ball is now emitting quite a lot of particles that appear to float in the air as if in a vacuum.        

 
Add gravity to the particles  
After being emitted, the particles float in place and linger for the length of the animated sequence. You will now add a 
gravitational field to the particles to make them drop to the ground in a more natural manner. 
 Fields help define the dynamics of the scene. Where keyframing controls objects based on what the animator chooses, 
dynamics built into Maya uses physics-based calculations to animate for you. 
1 Add gravity to the scene  
You will select the particle object and directly apply a gravity field so that the ball drops in the simulation. 
■  Make sure that you are on a frame where the particles are visible.  
■  Select only the particles. 
■  Select Fields → Create Gravity.  
■  Playback the scene. 

 
2 Edit gravity settings  
The gravity node is active and visible in the Channel box. You can set attributes for this node to edit the effect of the 
field. 
■  In the Channel box, set Magnitude to 30 for the gravityFieldShape node. 



 
 
4.a)Write about the menusets, shelf and hot box available in maya. 
 

Menu sets  
There are four menu sets in Maya: Animation, Modeling, Dynamics and Rendering. These allow you to focus on tools 
appropriate to a particular workflow.  
To choose a menu set:  
■  Select the menu set from the pop-up menu found at the left of the Status Line bar.  

To choose a menu set using hotkeys:  
■  Press the h key and choose the desired UI mode from the radial marking menu.  
To choose a menu set using function keys:  
■  Press F2 for Animation;  
■  Press F3 for Modeling;  
■  Press F4 for Dynamics;  
■ Press F5 for Rendering.  

 
 

The shelf  
Another way of accessing tools and actions is using the shelf. You can move items from the menu to the shelf to begin 
combining tools into groups based on your personal workflow needs.  
To add a menu item to a shelf:  
■  Press Ctrl+Alt+Shift then select the menu item. It will appear on the active shelf.  
To edit the shelf contents and tabs:  
■  Go to the Options menu and select Customize UI → Shelves...  
Hotbox  
As you have learned, pressing the spacebar quickly, pops a pane between full screen and its regular size. If you press a 
little longer, you will gain access to the hotbox. The hotbox is a user interface tool that gives you access to as much or as 
little of the Maya UI as you want. It appears where your cursor is and offers the fastest access to tools and actions.  
To access the hot box:  
■ Press and hold the spacebar. 

The hotbox offers a fully customizable interface element that provides you with access to all of the main menus 
as well as your own set of marking menus. You can use the Hotbox Controls to display or show as many or as 
few menus as you need, and you can configure up to 15 different marking menus for fast interaction. 

 
4.b) Write about menu items that let developer act on scenes in number of ways. 

Most of the tools and actions you will use in Maya are found in the main menus. The first five menus are always 
visible, while the next few menus change depending on which UI mode you are in. Menus and menu pop-ups that display 
a dotted line at the top can be ‘torn off’ for easier access. To tear off a menu: Pull down on the menu then release as your 
mouse hits the top of the menu. 
Menu sets 
There are four menu sets in Maya: Animation, Modeling, Dynamics and Rendering. These allow you to focus on tools 
appropriate to a particular workflow. To choose a menu set: Select the menu set from the pop-up menu found at the left 
of the Status Line bar. 
To choose a menu set using hotkeys: Press the h key and choose the desired UI mode from the radial marking menu. 
To choose a menu set using function keys: 

   Press F2 for Animation; 
   Press F3 for Modeling; 

Press F4 for Dynamics; 
   Press F5 for Rendering. 
5.a)Explain about building shark body and skeleton joints. 

Building Shark body  
The first step in building Shark, is to build the body and head. You will create these out of a single surface by sculpting a 
primitive sphere. To create the sphere, you will edit its input node using the show manipulator tool. 
1 Place a primitive sphere  
■  Select the Modeling menu set.  
■  Select Primitives → Create NURBS → Sphere.  
2 Change the sphere’s axis orientation  
■  In the Channel box, select the makeNurbSphere1 input node.  
■  Select the Show Manipulator tool. 



Several manipulators appear that allow you to edit parts of the input node. In the case of the sphere, the 
manipulators control the position of the main axis of the sphere. 

■  Press the x key to temporarily turn on grid snap and click-drag on the center of the top manipulator. 
■  Drag this manipulator down to the ground plane and place it along the X-axis with the help of grid snap. 
3 Edit, then delete construction history 
■  In the Channel box, go to the makeNurbSphere1 input node section and set the following: 

Radius to 4;  
Spans to 14.  
This increases the size of the sphere and adds more isoparm spans. This will offer more flexibility when 
sculpting the surface into the shape of a seal.  

■  Select Edit → Delete by Type → History. 

 
Building skeleton joints  
To animate Shark, you need to be able to deform the surface in a realistic manner. Moving and keyframing CVs would 
be a possibility, but would be a very time consuming process.  
Skeleton joints can be used to create a structure that can be bound to your surface for more controlled deformations.  
1 Draw the joints  
The joints can be placed to suit the existing surface’s shape. 
■  Go to the Animation menu set.  
■  Select Display → Joint Size → 25%.  
■  Select Skeletons → Joint Tool. 
■  Along Salty’s spine and head, click eight times to place joints as shown in the image below.  
■  Press Enter to finish drawing the skeleton. The joints are drawn as a series of small sphere’s connected by the 

skeleton’s bones. 
2 Change your selection mask  
■  From the black arrow next to the selection mode icons, select All Objects Off. 
■  Click on the Select Joints icon to activate this selection mask. 
■  Select the fourth joint up along the skeleton. 
3 Reroot the skeleton  
■  Select Skeletons → Reroot Skeleton. 

 
 
 
 
5.b)Explain about binding surface of shark to joints. 

Bind the surface to the joints 
 1 Bind the skin 
 You must now bind the surface to the joints. Before you start, you need to change your selection masks to include 
surfaces. 
■  From the black arrow next to the selection mode icons, select All Objects On The joints should already be 

selected. 
■  Press the Shift key and click on the surface to add it to the selection. 
■  Select Skinning → Bind Skin. 
2 Test the results 
■  Select the surface and press the 3 key to increase the surface smoothness.  
■  Select the first joint past the root.  
■  Select the Rotate tool.  
When you rotate a joint, you can see how the surface is set up to bend and twist with the joints. 

 



■  In the Perspective view panel, clickdrag on the rotate manipulator to see the bound skin move with the joints. 

 
 

3 Return to the bind pose  
■  Select the skeleton. 
■  Select Skinning → Go to Bind Pose. This sets the skeleton back to its bind pose.  
4 Save your work 

 
 
 
 
6.a)Explain about adding IK single chain handless,IK spline handle and cluster the spline curve. 

Adding IK single chain handles 
 To help control Salty’s flippers, you need to build inverse kinematic (IK) chains. These will let you control the flippers 
while Salty bounces the ball with her nose. 
1 Set the IK handle options  
■  Go to the Animation menu set.  
■  Select Skeletons → IK Handle Tool - ❐.  
■  In the option box, set the following: Current Solver to ikSCsolver.  
■  This tool is now active. Click Close. 
2 Add IK handles to the right flipper 
■  Click on Salty’s right shoulder joint to set the root of the IK chain.  
■  Click on the second-last joint on Salty’s flipper to place the IK handle. 
3 Add a second IK handle to the flipper  
■  Press the y key to reinvoke the IK Handle Tool.  
■  Click again on the second-last joint to start another IK chain.  
■  Click on the last joint on Salty’s flipper to place the IK handle. 
4 Add similar IK chains to the left flipper  
■  Use the same technique to add two similar IK chains to the left flipper. 
5 Test the IK chains on the right arm  
■  Select the two IK handles on the right flipper, making sure that you mask everything except the handles.  
■  Move the flipper in the Side view and watch the results in the Perspective view.  
■  All the joints in the flipper hierarchy are moved as one. As you move the IK handles, the interior joints bend. 
■  Press the z key to Undo this move. 

 
Add an IK spline handle 
The IK Spline solver is another type of IK solver that lets you use a curve to control the joint rotations. You can then 
animate the skeleton by either moving the joints along the curve, or by animating the position or shape of the curve. 
1 Set the spline IK options  
■  Select Skeletons → IK Spline Handle Tool - ❐.  
■  In the option box, make sure that the following options are set 
■  Click Close. This tool is still active. 
2 Add an IK spline handle 
■  Click on the joint at the nape of Salty’s neck as the root joint.  
■  Click on Salty’s nose joint as the end joint.  
An IK chain is drawn between these joints. At the same time, a curve has been placed along the joints. You can use the 
panel’s Show menu to see this curve. 
3 Show the curve in the Front view  
■  Change the Side view to another Front view panel.  
■  In the new Front view panel’s Show menu, turn Joints and IK Handles to Off. 
4 Test the effect of the new chain  
■  Select the new curve.  
■  Move the new curve up in the Front view. 
■  Undo this move.  



5 Set a key on the flippers  
■  In the Perspective window, Select all four of the IK handles belonging to the flippers. 
■  Move the IK handles along the Yaxis to raise the flippers above the ground level just a little.  
■  Set the Time slider to frame 1.  
■  Press Shift w to set keys on only the translation channels belonging to the IK handles. 
6 Re-test the chain  
■  Select the new curve.  
■  Move the new curve down in the Front view. 
■  Move the curve up 
■  Undo these two moves. 

 
Cluster the spline curve 
1 Cluster the curve 
 By adding a cluster to the new curve, you will be placing the curve’s CVs into a special cluster set. 
■  Select the spline curve.  
■  Select Deformations → Cluster. 
2 Edit the cluster weights 
■  Select Windows → General Editors → Set Editor...  
■  In the Set Editor, scroll down to the cluster3set listing. 
■  Click on the triangle icon next to cluster3Set to see a list of the CVs. The set contains all four of the curveShape 

CVs.  
■  Click on the first CV in the list. 
■  Go to the value field at the bottom of the window.  
 Type 0.25, then press the Enter key. 
■  Use the same technique to set the next two CVs to 0.5 and 0.75.  
■  Leave the last CV set to 1.0. 
■  Since one of the CVs is now the current selection, once again Select the cluster handle using the small ‘c’ icon.  
■  Move the cluster down along the Yaxis. 
■  Move the cluster out along the Zaxis using the manipulator in the Perspective view. 
4 Display the cluster’s selection handle  
■  With the cluster handle selected, select Display → Object Components → Selection Handles. 
5 Move the selection handle  
■  Press F8 to go into component selection mode.  
■  Turn off the points selection mask and turn on the handles mask. 
■  Move the handle along the Y-axis to place it above Salty’s head. 
■  Turn off the handles selection mask and turn on the points mask.  
■  Press F8 to go back to object selection mode. 

 
 
 
 
6.b)Write about creation of a ball, connecting it to a shark’s nose and animating them. 

Create a ball  
To animate Salty bouncing a ball, you need to create the ball itself. This ball will use a simply hierarchy of grouped 
nodes. One node will be used to animate the bounce of the ball while the top node will be used to constrain the ball to 
Shark’s nose. 
1 Create a sphere  
■  Go to the Primitives menu and select Create NURBS → Sphere.  
■  Name this node ball.  
■  Press 3 to increase the surface smoothness.  
■  Click on the input node in the Channel box and set the following: Radius to 1.5. 



■  Move the sphere up until it sits just above the ground plane. 
2 Delete history  
■  Select Edit → Delete by Type → History.  
3 Group the sphere to itself twice  
This will create a node hierarchy for your animation. One node will be used to animate the ball’s bounce while the top 
node will be constrained to Salty’s nose.  
■  Select Edit → Group.  
■  Name this node ballBounce.  
■  Press the g key to repeat this action.  
■  Name this node ballConstrain.  
4 Make the ball a passive rigid body  
 In a later stage of this lesson, you will animate the ball using dynamics. This requires that the ball is defined as a 
rigid body.  
■  Press the down arrow twice to select the lower ball node.  
■  Go to the Dynamics menu set.  
■  Select Bodies → Create Passive Rigid Body 

 
 

Connect the ball to Shark’s nose 
1 Constrain the ball to Salty’s nose joint  
■  Go to the Animation menu set.  
■  In the Front view panel, select Show → None, then Show → Joints.  
■  Select the nose joint of the skeleton.  
Only the round joint icon at the end of the skeleton should be highlighted. The first bone should not be highlighted.  
■  Click on the Select by hierarchy button. 
■  Press the Shift key then Select the ball. 
■  Select Constraints → Point 
2 Move the cluster to balance the ball  
■  Press F8 to go back to object selection mode.  
■  Select the cluster handle using its selection handle.  
■  Move the cluster up until Salty appears to be balancing the ball. 
3 Put a selection handle on ballBounce 
■  Select the ball.  
■  Press the up arrow key to move up the hierarchy to the ballBounce node.  
 Use the Channel box to confirm that the correct node is selected.  
■  Select Display → Object Components → Selection Handles.  
■  Press F8 to go into component selection mode.  
■  Turn off the points selection mask and turn on the handles selection mask.  
■  Click-drag a selection box around the cluster’s selection handle to pick this component.  
■  Move the handle along the Y-axis to place it above Salty’s head. 
■  Turn off the handles selection mask and turn on the points mask.  
■  Press F8 to go back to object selection mode. 

 
 

Setting up for the animation  
To get ready to animate the scene, you will set up the animation preferences, refine the display of Salty in the Perspective 
view, and use the channel control to make it easier to set keys on the clusterHandle and ballBounce nodes.  
1 Set the length of the animation 
■  At the right end of the Time slider, click on the animation preferences button.  
■  Click on the hidden tabs at the top right of this window. 
■  Choose Units from the pop-up menu and set the following: Time to NTSC (30 fps).  
■  Now click on the Animation tab and set the following: 

Time slider to 1 and 450;  
Range slider to 1 and 450;  
Playback Speed to Normal. 

■  Click on Save.  
2 Prepare the Perspective view  



It is a good idea to focus on how the surfaces look when animated.  
■  In the Perspective view panel, select Show → Joints, Show → Deformers, and Show → IK handles to turn these 

object types off for this window. 
3 Restrict the cluster handle channels  
■  Select the cluster handle for Salty’s neck using its selection handle.  
■  Select Window → General Editor → Channel Control.  
■  Press the Ctrl key and click on all the rotate and scale channels, and then the visibility channel. Press the Move 

>> button to make these channels non-keyable. 

 
 
 
7.a)write about adding details to the face of shark. 
  Build an eyeball hierarchy 
  use an aim constraint 
  Apply lattice and cluster deformers 

To start building Salty’s eye, you will build and texture an eyeball centered around the origin. Later, you will position it 
more closely to Salty’s head. 

 1 Place a primitive sphere 
  Go to the Modeling menu set.Select Primitives 
  Create NURBS 
  Sphere 
  Press the 3 key to increase the display smoothness of the sphere. 
  In the Channel box, rename the sphere1 node to eyeball. 
 2 Use show manipulator tool to edit axis 
  Dolly in to see the sphere from a closer point of view. 
  In the Channel box, select the make NurbSphere input node. 
  Select the Show Manipulator tool. 
  Press the x key to temporarily turn on grid snap and click-drag on the center of the top manipulator. 
  Drag this manipulator down to the ground plane and place it along the X-axis with the help of grid snap. 

 
  This orientation will facilitate the mapping of a ramp texture to the sphere later. 
 3 Edit the input node values 
  In the Channel box, change the following attributes for the make NurbsSphere node: 
  Radius to 0.5 
 4 Create the eye shading group 
  The seals eyes will use a phong material node that is shiny with a bit of translucence. 
  Select Window Multilister 
  This opens a Multilister as a floating window. Maya’s various window types can be used as either panels or 
  as floating windows. 
  Create a phong material node using the technique taught in earlier lessons. 
  Rename the shading group node to eyeSG and the material node to eyePhong 
 
7.b)Write about creation of background lighting in maya. 

Creating background lighting  
With the main spot lights established, it is necessary to light the background wall of the stage. You will also 
create additional ambient lighting. 
1 Create and position a spot light 
■  Select Lighting → Create Spot Light. The light is positioned at the origin.  
■  Select Show Manipulators.  
■  Position the manipulators so that the light is shining down on the center of the back wall as shown. 



■  If you cannot see the lights with hardware rendering, use the Look Through Selected to position the 
light. 

2 Set spot light parameters 
In the Channel box, select the new light’s spotLightShape node and set the following:  

RGB to 1 1 0.75;  
Intensity to 0.5;  
Cone Angle to 60;  
Penumbra Angle to 20;  
Dropoff to 5. 

3 Duplicate and position the spot lights 
■  Move the spot light to one side of the Z-axis.  
■  Duplicate the spot light.  
■  Move the new light to the other side of the axis.  
■  Duplicate and Move two more spot lights. 
■  In the Channel box set: Intensity to 0.2.  
■  In the Attribute Editor set:  

Color to a pale turquoise;  
Ambient Shade to 0.75. 

4 Adjust all of the spot lights 
■  Select all four of the background spot lights. 
■  In the Channel box, click on the top light’s spotLightShape node.  
■  Change the Cone Angle to 70. The cone angles are now set for all four of the selected lights. 
5 Add an ambient light 
■  From the Rendering menu set, select Lighting → Create Ambient Light. 
■  Move the light behind Salty and slightly above the deck surface 

.  
 
 
8.a) Explain about texturing water and mapping it as a displacement map. 

The water shading group  
The water is going to be textured using a color texture that is also mapped as a displacement map. This means that the 
surface will raise and lower based on the value of the map texture. Compared to bump mapping, a displacement map is 
slower but achieves more realistic results. 
1 Create and assign a new shading group  
■  Create a new Blinn material node with shading group.  
■  Rename the nodes waterSG and waterBlinn. 
■  Assign waterSG to the water surface. 
2 Edit transparency, specular and raytrace attributes  
■  Open the waterBlinn node in the Attribute Editor and set the following:  

Transparency to about 0.3. 
In the Specular Shading section:  
Eccentricity to about 0.06;  
Specular Roll Off to over 0.9;  
Specular Color Value to 0.7;  
Reflectivity to 0.4. 

■  In the Raytrace Options section:  
RT Refracted Color to On;  
Refractive Index to 1.33;  
Refraction Limit to 1;  
Reflection Limit to 1. 

3 Create a water color map  
■  In the Multilister, select Edit → Create...  
■  In the Textures section of the Create Render Node window, turn on With New Texture Placement. ■ In the 2D 

texture 
■  Rename this node waterColor.  
■  In the Water Attributes section of the Attribute Editor, set the following:  

Number of Waves to 20;  
Wave Amplitude to 0.075;  
Smoothness to 1.0.  

■  In the Color Balance section: Color Gain to a bright turquoiseblue; Color Offset to a dark saturated blue; 
4 Connect the map to the shading group  



■  Using either the Multilister or Hypergraph, click-drag the waterColor texture node onto the waterBlinn material 
node. 

5 Create a displacement node  
■  Open the waterSG node’s Attribute Editor. 
■  View the shading group in the Hypergraph. 
6 Animate the waves 
■  Set the Time slider to frame 1.  
■  Open the waterColor node’s Attribute Editor.  
■  With the right mouse button, click and hold on the Wave Time attribute.  
■  From the pop-up menu select Set Key. 
■  Change the Wave Frequency to 5.0.  
■  Select Set Key from the pop-up menu for the Wave Frequency attribute. 
■  Change the current frame to the last frame of the animation.  
■  Change the Wave Time to 2.  
■  Select Set Key.  
■  Change the Wave Frequency to 6.0.  
■  Select Set Key. 
7 Change the direction of the waves  
■  Open the texture placement node for the waterColor node in the Attribute Editor and set the following: Rotate 

Frame to 90. 
8 Test render the water material  
■  Go to first frame button in the Time slider.  
 This should pop your camera back to its initial position.  
■  In the Render View panel, select Redo Previous Render. 
9 Increase the surface tessellation  
■  Select the water surface.  
■  Open the Tessellation Criteria section.  
■  In Initial Tessellation Controls section of the Attribute Editor:  

Set Number U to 50;  
Set Number V to 50.  

■  In the Render View panel, select Redo Previous Render. 
 
8.b) write layered shaders available in maya. 
  

LAYERED SHADERS  
A unique material node type in Maya is the layered shader node. This material node lets you layer other material nodes 
together to create more sophisticated effects. The layered shader can be fed by other material nodes and can therefore 
combine different material effects in one shading group. 
The wall shading group  
The back wall is going to be designed to look like a plaster wall that is peeling to reveal wood panels below. A layered 
shading group will be used to achieve this effect. 
1 Create a layered shading group  
■  Create a Layered Shader material node with a shading group node.  
■  Rename the nodes wallSG and wallLayered. 
■  Assign the shading group to the back wall surface. 
2 Create the paint material  
■  In the Materials tab of the Create Render Node window:  

Turn off the With Shading Group option.  
Create a Blinn material node.  

■  In the Multilister, open the Materials tab.  
■  Open the Attribute Editor for the new Blinn node.  
■  Rename the new node paintBlinn.  
■  In the Specular Shading section:  

Set Eccentricity to 0.4;  
Set Specular Roll Off to 0.9;  
Set the Value of the Specular Color to 0.8;  
Set Reflectivity to 0.1 . 

3 Add the material to the layered shader  
■  Open the wallLayered node’s Attribute Editor. The Layered Shader Attributes section contains a green default 

swatch. This is the default layer.  
■  In the Multilister, drag the paintBlinn node onto the wallLayered node. 
■  Click on the boxed “X” below the green swatch. 
4 Map an image stencil to the color  
■  Open the paintBlinn node’s Attribute Editor.  
■  Click on the Map button for the Color attribute.  
■  In the 2D Textures section of the Create Render Node window:  

Turn With New Texture Placement on;  
Select As stencil;  
Create a new File node. 

5 Reference an image file  



■  Open the Attribute Editor for the file1 node.  
■  Click on the Browse button next to Image Name. The file browser window opens.  
■  In the sourceImages directory, open the logoStencil.tiff file. 
■  In the Effects section:  
          Set Filter to 0.2 
6 View the shading group in the Hypergraph 
■  Highlight the wallLayered node in the Multilister.  
■  In the Multilister, select Window → Hypergraph Highlighted.  
■  Press the Ctrl key and double-click on the shared texture placement node. This allows you to change the node 

name directly in the Hypergraph.  
■  Enter the new name placeLogo. 
7 Position the image  
■  Open a Side view panel then dolly until you can see the entire back wall.  
■  Select the placeLogo node in the Hypergraph.  
■  In the Attribute Editor, change the Rotate UV to -90.0.  
■  Click on the Interactive Placement button. 
■  With the middle mouse button, click-drag the red square, at the midpoint of one of the surface edges, to a new 

position. 
■  Adjust the four sides of the manipulator until the texture is positioned as shown. 

 
 ■   In the Render View panel, select Redo Previous Render. 
8 Create the image mask  

■  In the Create Render Node Window:  
Turn With New Texture Placement to off;  
Set the 2D Texture type to Normal;  
Create a File texture node. The new file2 node appears in the Textures section of the Multilister.  

■  In the Attribute Editor, click on the Browse button next to Image Name.  
■  Open the logoMask.tiff image file.  
■  In the Effects section: Set Filter to 0.2. 
9 Connect the stencil to the shading group  
■  Open the Attribute Editor for the stencil1 utility icon.  
■  Drag the new mask file2 node onto the Mask attribute in the Stencil Attributes section. 
■  In the Multilister, drag the placeLogo node onto the file2 mask node. 
■  View the shading group in the Hypergraph. 
10 Modify the paint color 
■  Open the Attribute Editor for the stencil1 utility node.  
■  Open the Color Balance section. 
■  Change the Default Color swatch to an appropriate color. 
■  Re-render the scene to see the effect of the shading group to this point. 

 
9.a) write about adding functions to UL in MEL. 

MEL stands for Maya Embedded Language. MEL is built on top of Maya’s base architecture and is used to execute 
commands that you use to build scenes and create user interface elements. In fact, every time you click on a tool, you are 
executing one or more MEL commands. 
Adding the function to the UI 
 
1 Creating a shelf button  
■  In the Script Editor, select the text blink 10.  
■  Click on the selected text with the middle mouse button and drag up to the shelf. 
 
2 Creating a blink marking menu set  
■  Select Options → Customize UI → Marking Menus...  
■  Click on the Create Marking Menu button.  
■  Click on the top middle square with your right mouse button and select Edit Menu item... from the pop-up menu.  
■  In the Edit window, type Blink 10 in the Label field.  
■  In the Commands(s): field, type blink 10.  



■  Click Save and Close.  
■  Repeat for the other quadrants to set up blink commands that use a blinkDelay of 20, 30 and 40.  
■  In the Menu Name field, enter: blinking. 
 
3 Prepare the blink marking menu for a hotkey  
The blink marking menu now needs to be set up.  
■  In the marking menu customize window, set the following: Use Marking Menu in to Hotkey Editor. Now the 

marking menu can be set up in the Hotkey Editor so that it can be evoked using a hotkey.  
■  Click the Apply Settings button then Close. 4 Assign the blink marking menu to a hotkey  
■  Select Options → Customize UI → Hotkeys... and set: Display Mask to Show All. 
■  Scroll to the bottom of the list and click on the blinking (Press) listing.  
■  In the Key Settings section, set the following: Key to b; Action to Press.  
■  Click on the Query Key button to verify that this key is not in use.  
■  Press the Apply New Settings button.  
■  Scroll to the bottom of the list and click on blinking (Release).  
■  In the Key Settings section, set the following: Key to b; Action to Release.  
■  Press the Apply New Settings button then Close. 
5 Use the new marking menu  
■ Go to frame 80.  
■  Click and hold on the b key, then pick one of the blinking options from the marking menu. 

 
 
 
9.b) Write about building custom UI script.  
 

Building a custom UI script  
In the next section, you will write a second script that will build a custom user interface window that includes a slider for 
the blinkDelay variable and a button that executes the blink procedure you scripted earlier. In Maya, you have the ability 
to use MEL to build custom user interface elements. 
 
1  Start a new Jot file  
2  Adding the opening comments 
 
Start the script with a commented header that helps others read your work. While this was taught earlier, it can never be 
emphasized enough.  
■  Type the following: 
 //  
// Creation Date:: Today’s date 
// Author: Your name here  
//  
// Description:  
// Learning Maya tutorial script  
// This script builds a custom user interface  
// for executing the blink procedure  
// and for setting the blink delay  
// 

 
3 Declare a get info procedure  
You are now going to create a procedure called blinkGetInfo that will be used to get the blinkDelay value from a slider, 
which you will build later in the script. Since the value set in the slider is meant to be the chosen value for the blink, this 
procedure queries the slider to set the blinkDelay, and then adds that value next to the blink command. 
 
■ Type the following: 
 

global proc blinkGetInfo()  
{  
// get necessary information from Maya  
 float $blinkDelay = ‘intSliderGrp -query -value blinkWindow|columnLayout|delaySlider‘;  
blink $blinkDelay;  
} 

4 Declare a second user interface procedure  



You are now going to declare a procedure that will build a floating window. This window will look and act like any other 
window in Maya but will be designed to help you put a blink to Salty’s eyes.  
■ Type the following:  
 global proc blinkWindow() { 
 
5 Remove any existing blink windows  
As you start a user interface script, it is a good idea to check if the same UI element already exists in the scene and, if so, 
then to delete it. This makes sure that your new element is the only one recognized by Maya at any one time.  
■ Type the following: 
  // clean up any existing blinkWindows 
  if ( (`window -ex blinkWindow`) == true ) deleteUI  
 blinkWindow; 
 
6 Build the window called blinkWindow  
The next part of the script is designed to build a window that is 400 pixels wide and 75 pixels tall. You will call it Blink 
Control in its title bar but Maya will know of it as blinkWindow. 
■ Type the following:  

window  
-width 400  
-height 75 
-title "Blink Control"  
blinkWindow; 

 
7 Form a column layout  
Within the window, you need to organize your user interface elements. One method of organization is a columnLayout. 
This sets up a column with a particular spacing in relation to the window. 
■ Type the following:  

columnLayout  
-columnAttach "right" 5  
-rowSpacing 10  
-columnWidth 375  
columnLayout; 

 
8 Create a slider group  
Within the layout, you want to build a slider that lets you set the blinkDelay value. MEL offers you preset kits using 
special group commands that build several UI types in one go. The intSliderGrp builds a slider along with a field for 
seeing the resulting value and for entering the value yourself. This slider is set to integer values since frames are 
generally set in whole numbers. The flags let you set the various values for the minimum and maximum settings of the 
slider. 
■ Type the following: 

  intSliderGrp   
 -label "Blink Delay"  
-field true  
-minValue 2  
-maxValue 30  
-fieldMinValue 0  
-fieldMaxValue 100  
-value 10  

 delaySlider; 
 
9 Create a button  
The next part of the script builds a button that you will be used to execute the blinkGetInfo procedure, which in turn uses 
the blinkDelay value from the slider to execute the blink command. At the end, you will enter setparent to link the button 
to the columnlayout. 
 
■ Type the following: 

button  
-label "Blink"  
-width 70  
-command "blinkGetInfo"  
button;  
setParent ..; 

 
10 Show the window  
You are almost finished, except that you must tell Maya to show the window.  
■ Type the following: 
  showWindow  blinkWindow; 
 
11 Finish the script  
Finally, you must complete the procedure then make one final declaration of the blinkWindow procedure name.  



■ Type the following: 
} 
blinkWindow; 

 
12 Saving the script  
You can now save your script into your Maya scripts directory. 
 ■  In your text editor, save the script using the following path: /home_directory/maya/scripts/blinkWindow.mel 
 
13 Test your script  
■  In the Command line or the Script Editor, type the following:  
 blinkWindow < enter > 
 
The window should open. You can now set the Time slider to a new time, and then set the blink delay using the slider; 
pressing the button will key the blink. 

 
 
 
 
 
 
  

 


